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Introduction to BSC Designer PRO
BSC Designer PRO is a strategy execution software which business professionals use to manage their scorecards, KPIs, and strategy maps.

Use BSC Designer PRO to:

Describe business goals and connections between them on a strategy map
Track strategy execution with leading and lagging indicators
Do a quick analysis of the indicators, forecast their values
Visualize performance data on dashboards
Keep the team informed about important changes of KPIs

Below is a review of the most important functions of BSC Designer PRO.

Track KPIs. Manage the most important performance indicators. Define the relative weight of the metrics. Track leading and
lagging performance of business goals. Read more...

Strategy maps. Create visually appealing strategy maps. Show the cause and effect logic between the goals. Visualize aligned
initiatives and indicators. Use strategy maps to discuss new ideas with your team. Read more...

Reports. Create performance reports. Calculate the total cost of all initiatives. Prepare an action plan report. Share your findings
on the presentation slides. Read more...

Import data for KPI. Import performance data from a spreadsheet or SQL database. Cascade scorecards by linking goals and
indicators. Read more...

Alerts. Keep your team informed. Setup alerts for the most important indicators. Track new initiatives added or indicators that have
gotten into a red zone. Read more...

More features:

Analyze performance of the indicators
Connect to BSC Designer Online
Survey experts about KPIs

2 / 32

file:///P:/Project/Projects/BSC_Designer/chmhelp-pdf-generator/sources/kpis.htm
file:///P:/Project/Projects/BSC_Designer/chmhelp-pdf-generator/sources/kpis.htm
file:///P:/Project/Projects/BSC_Designer/chmhelp-pdf-generator/sources/kpis.htm
file:///P:/Project/Projects/BSC_Designer/chmhelp-pdf-generator/sources/strategy-map.htm
file:///P:/Project/Projects/BSC_Designer/chmhelp-pdf-generator/sources/strategy-map.htm
file:///P:/Project/Projects/BSC_Designer/chmhelp-pdf-generator/sources/strategy-map.htm
file:///P:/Project/Projects/BSC_Designer/chmhelp-pdf-generator/sources/reports.htm
file:///P:/Project/Projects/BSC_Designer/chmhelp-pdf-generator/sources/reports.htm
file:///P:/Project/Projects/BSC_Designer/chmhelp-pdf-generator/sources/reports.htm
file:///P:/Project/Projects/BSC_Designer/chmhelp-pdf-generator/sources/import-values.htm
file:///P:/Project/Projects/BSC_Designer/chmhelp-pdf-generator/sources/import-values.htm
file:///P:/Project/Projects/BSC_Designer/chmhelp-pdf-generator/sources/import-values.htm
file:///P:/Project/Projects/BSC_Designer/chmhelp-pdf-generator/sources/alerts.htm
file:///P:/Project/Projects/BSC_Designer/chmhelp-pdf-generator/sources/alerts.htm
file:///P:/Project/Projects/BSC_Designer/chmhelp-pdf-generator/sources/alerts.htm
file:///P:/Project/Projects/BSC_Designer/chmhelp-pdf-generator/sources/analysis.htm
file:///P:/Project/Projects/BSC_Designer/chmhelp-pdf-generator/sources/integration-with-online.htm
file:///P:/Project/Projects/BSC_Designer/chmhelp-pdf-generator/sources/data-series.htm


Scorecard Properties in BSC Designer
Use the Document properties command in the File menu to access additional scorecard customization settings.

Main Tab

The Main tab contains information about the scorecard:

Author name
Scorecard name
Description

Measure Units Tab

Set default measure units used for the new indicators
Import measure units from other scorecards
Export measure units
Add new measure unit
Use Custom text fields to define qualitative measurements

Custom Values & Files Tabs

These two tabs help to customize reports:

Use Custom Values to insert text into the report
Use Custom Files to add some files into the report

SQL Tab

The SQL tab presents settings for SQL indicators.

Password Tab
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Use text fields on the Password tab to assign a password for reading and writing.

Value

Define on this tab:

How the baseline is updated in BSC Designer
Display settings for leading and lagging indicators
The default value for the inheritance
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Seamless Integration with BSC Designer Online
Facilitate team work and permission management by integrating BSC Designer PRO with cloud-based BSC Designer Online.

Please note: the subscription for BSC Designer Online is sold separately.

First Time Setup

1. Go to the menu Tools > Application options > Teamwork tab
2. Enter data into BSC Online credentials
3. Click on Log into existing account

Access Scorecards

The File menu allows accessing scorecards from BSC Designer Online:

Open the scorecard from the cloud using Check in project command
Save the scorecard back to the cloud account using Check out project command
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Automate Scorecard Reporting with Command Line Interface in BSC Designer
PRO
Use the command line interface to automate scorecard reporting and integrate BSC Designer PRO with another business application.

The interface for the command line is:

[filename] [-export filename] [-overwrite] 

Goals and KPIs Report

scorecard_file.bsc -export report.html -goalsandkpis -report-profile %profile_name_or_index%

Where %profile_name_or_index% is 0, 1, 2, or "Custom report name" (with quotes).

Scorecard Performance Report

Specify the start and end date for the report, add -html option:

bsc_designer.exe scorecard-file.bsc -date1 01.01.%last-year% -date2 01.11.%last-year% -html -export 
report.html -overwrite

Export to Excel

"scorecard-file.bsc" -export "report.xls" -overwrite

Export to Excel for Specific Date

To generate a report for a certain date, use this syntax:

"scorecard-file.bsc" -export "report.xls" -overwrite -date 01.24.%last-year% 

Note: the date must be according to Windows settings (for example, DD.MM.YYYY or MM.DD.YYYY).

PowerPoint Report

Use the -powerpoint option to generate a PowerPoint report:

bsc_designer.exe scorecard-file.bsc -powerpoint -export report.ppt -overwrite
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Strategy Map Report

Below is a command line syntax for strategy maps.

bsc_designer.exe scorecard-file.bsc -export PictureFileName -StrategyMap [-StrategyMapPlacement ] [-
StrategyMapLevel ]

bsc_designer.exe scorecard-file.bsc -export REPORTFILE -allmaps

Export of an existing map:

bsc_designer.exe scorecard-file.bsc -export "C:\output-file.jpg" -StrategyMap

Use the -overview option to generate overview report:

bsc_designer.exe scorecard-file.bsc -html -export report.html -overwrite -overview

Export of a "snowflake" map:

bsc_designer.exe scorecard-file.bsc -export
"C:\output-file.jpg" -StrategyMap -StrategyMapPlacement SnowFlake -StrategyMapLevel 1

Export all supported strategy maps:

bsc_designer.exe scorecard-file.bsc -export C:\report.html -allmaps

Updating SQL indicators

To update SQL indicators via the command line, use this syntax:

bsc_designer.exe scorecard-with-sql-indicators.bsc -silentsqlupdate
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Manage Goals and KPIs in BSC Designer PRO
Manage the KPI scorecard in BSC Designer. Automate all of the calculations taking into account targets, leading and lagging indicators.

Create a New Indicator/Goal

1. Go to the KPI tab
2. Select a parent item
3. Click on the New Item button on the toolbar
4. Use the tabs below to adjust the created item

General Tab

Name - the name of the indicator
Description - a short description of the indicator
Measure - measure units that correspond to the indicator
Initiatives - action plans for the item

Data Tab

A stop-light is linked to the performance (click to customize)
Value field - the value for the indicator associated with the date selected in the internal calendar

Data source button - access data sources for an indicator

Baseline and Target - a scale for the progress* calculation
Min and Max - a scale for the performance* calculation
Simple mode - a checkbox to hide/show the min and max fields

* The calculations of the performance and weight are explained in Scorecard and KPIs 101.

The Value drop list defines how the value of the goal is calculated; for example, it can be:

Weighted average of the values of the child indicators, or
Self-standing when the software won't take into account child indicators

Performance Tab

Weight - importance of the indicators compared to other indicators aligned with the same goal
Optimization - the mathematical function that BSC Designer uses to calculate the performance
Raw data - disables performance calculation for the indicator

The Performance drop list defines how the performance of the goal is calculated. For example, it can be:

Weighted average of the performance of the child indicators, or
Self-standing when the software won't take into account child indicators

The software calculates leading and lagging performance of the goal using the data of the aligned indicators.
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Context Tab

Glyph 1 and Glyph 2 - select a glyph for the indicators on the strategy map
Indicator type - select whether the indicator is a Leading or Lagging one in the context of the business goal
Strategic theme - changes the color of the goal on the map
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Initiatives in BSC Designer PRO
Use initiatives to describe action plans for the goals and KPIs; include data for budget, timeline and the person responsible.

To access initiatives:

1. Go to the KPI tab
2. Select any indicator or goal
3. Switch to the General tab below
4. Click on the Initiatives button

The settings for an initiative:

Name of the initiative
Date to visualize initiative on the Time chart
Details - additional information about the initiative
Budget associated with the initiative
Timeline - start date, deadline, and duration for an initiative
Person responsible for the initiative; this is used on strategy maps and for the alerts
Documents - a link to the external documents

BSC Designer can generate an Action plan report that will include all the initiatives.
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Update Interval for KPIs
Learn to keep the data for the KPIs organized, specify required update interval, and let BSC Designer PRO help your team to follow it.

Assign an update interval:

1. Go to the KPI tab, select an indicator
2. Select Edit value command in the KPIs menu
3. Use the controls from the Update group
4. Select reporting period
5. Select reporting date in the period
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Value Inheritance for KPIs in BSC Designer PRO
Define indicators that should inherit their values from the historical data and those that should use specifically entered values.

Change the inheritance setting:

1. Go to the KPI tab
2. Select any indicator
3. Go to the menu KPIs > Edit Values
4. Use the Values inheritance option

Change the default inheritance in the menu File > Document properties > Value tab > Use inherited values for indicator.
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Data Grouping in BSC Designer PRO
Report aggregated values of indicators, group performance data as average or sum of changed.

Select a grouping type for an indicator:

1. Go to the KPI tab
2. Select any indicator
3. Select the Edit values command in KPIs menu
4. Use the Group by drop list

To change the grouping period, use the Group by control:

In the report dialog
Under the charts
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Data Source for KPIs in BSC Designer PRO
Learn how to power KPIs with different data sources including Excel spreadsheets, other scorecards, databases, and user surveys.

Access Data Sources

Switch to the KPI tab
Select any indicator
Switch to the Data tab
Click on the Data source button
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Import Values for Indicators From Spreadsheet or CSV
Learn how to import data from an Excel spreadsheet into the performance indicators in BSC Designer PRO.

Prepare a Template (optional)

1. Create a scorecard with a KPI structure
2. Select the Export values command in KPIs menu
3. Follow the steps of the export master

Import From Spreadsheet or CSV

1. Select the Import values command in KPIs menu
2. Select the source for the data
3. Click Next
4. Preview data
5. Click Next and if needed:

Click on the column name to associate it with the correct KPI property
Use swap columns and the rows  button

Change settings in the Date group

6. Click Next
7. Change import settings if needed
8. Click Next
9. Preview recognized data

10. Click Finish

GUID Property

GUID stands for Globally Unique Identifier
GUID helps to match the indicator in BSC Designer with the indicator in a spreadsheet
When importing, GUID has priority over a parent field

Link KPI Value to a Certain Cell in an Excel File

An alternative to importing from a spreadsheet is linking the KPI value to a certain cell in an Excel file:

1. Go to the KPI tab
2. Select any indicator
3. Switch to the Data tab below
4. Click the  Data Source button
5. Select the Link to MS Excel
6. Follow the steps of the import master

What is a Named Range?
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Name range is a more reliable alternative to addressing cells by their coordinates. More in Excel manual.

Additional Tips

The value will be imported into the date selected in the internal calendar
Use Update imported indicators in the Tools menu to repeat import

Importing vs. Linking

Import data to load scorecard with many values for many indicators
Link to the specific cell to update a few important values regularly
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Cascading Scorecards in BSC Designer PRO
Ensure business scorecards are connected. Learn how to cascade scorecards by indicators or business goals in BSC Designer PRO.

Create Imported Indicator

1. Go to the KPI tab
2. Select any indicator
3. Switch to the Data tab below
4. Click the Data source button
5. Select the Link to BSC Designer project option
6. Select one of the importing options:

From file - connect to the locally stored scorecard
BSC Online - connect to the scorecard stored in BSC Designer Online (recommended)
Local - connect to the indicator in the current scorecard

7. Click the Select button
8. Select the name of the indicator to import
9. Click OK to finish

Useful Tips

Use Update imported indicators in the Tools menu to update imported values
The name and the weight of the imported can be customized in the recipient scorecard
The value of the imported indicator can be changed in the source scorecard only
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Import Data from External Database with SQL Query
Learn how to power performance metrics on the scorecard by connecting to a database using SQL indicators.

Creating SQL Indicator

1. Go to the KPI tab
2. Select any indicator
3. Switch to the Data tab below
4. Click the KPI Data Source button
5. Select Link to SQL Database
6. Select a database with local or web access

Creating Connection String

1. Click the Build button to create a connection string

2. Select a data source (available data sources depend on the ADO drivers installed), for example ODBC drivers:

3. Click Next
4. Switch to Use connection string in Specify the source of data section
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5. Click the Build button
6. Go to the Machine data source tab
7. Select data source (for example, "Excel Files")

8. Double-click on it
9. Select an MS Excel file, click OK

10. Click the Test button

Creating SQL Query
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1. Click the Build button for SQL statement

2. Select a table and click the Next button

3. Select a column from the Result field drop list

4. Select "Date" from the available field list, select "=" as a condition, and "Date" in the drop list

5. Click "Finish" to apply changes

The example SQL query:

SELECT `Value`,`Date`
FROM `all`
WHERE
 ( `Date` = :Date ) 
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Parameters Supported in Request

:Date - the date selected in BSC Designer
:UpdatePeriodStart - the first date of the current update interval
:UpdatePeriodEnd - the last date of the current update interval
:ItemName - the name of indicator
:Max - MAX value of indicator
:Min - MIN value of indicator
:FileName - the file name of the current scorecard

Getting Aggregated Values from a Data Source

1. Specify update interval for an indicator
2. Replace :Date parameter in SQL query with :UpdatePeriodStart and :UpdatePeriodEnd parameters

The example SQL query that aggregates data:

SELECT sum(Value) as AggregatedValue,`Date`
FROM `all`
WHERE
 ( `Date` BETWEEN :UpdatePeriodStart and :UpdatePeriodEnd ) 

Additional ideas

Use the File > Document Properties > SQL tab to find additional settings for SQL indicators
Find the Data via SQL scorecard in the samples folder as an example of SQL indicator setup
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Build a KPI Using an External Data Source in XML or JSON Formats
Learn how to power KPIs on the scorecard with data generated by external web scripts in XML or JSON formats.

Create HTTP Indicator

1. Go to the KPI tab
2. Select any indicator
3. Switch to the Data tab
4. Click the KPI Data Source button
5. Select Link to a web-based script option
6. Specify the access URL and necessary parameters

Script Parameters

%%name%% - the name of the indicator
%%date%% - date selected in internal calendar

Script Response

BSC Designer PRO will search for a value field in the response. The server response should be in XML or JSON format, for example:

20.1My indicator

Response in JSON format:

{"value":20.1,"name":"My indicator"}

22 / 32

file:///P:/Project/Projects/BSC_Designer/chmhelp-pdf-generator/sources/data-sources-for-kpi.htm


Data Series in BSC Designer PRO
A value of the KPI can be defined by the opinions of several experts. Learn how to manage with data series in BSC Designer.

Enable Data series

1. Go to the KPI tab
2. Select any indicator
3. Switch to the Data tab below
4. Click the Data source button
5. Select the Data Series option
6. The Data series tab will appear

Data Series and Surveys

Following analogy with surveys:

Group name is a name of the survey
Series are the names of the experts
KPIs are the questions asked
Group results are the results of the survey

Entering Data

Enter the data for the KPI directly in the Data series table or
Make a required series active (via Active column) and enter data on the KPI tab

Useful Tips

To calculate the group value, the software uses the indicator's grouping type
There is a data series "Series" report in menu Reports > KPI Reports
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Strategy Maps in BSC Designer PRO
Describe a strategy of the organization on the strategy map; explain how goals are connected, align indicators, and action plans.

Create a New Strategy Map

1. Go to the Strategy Map tab
2. Click the Add strategy map button
3. The Placement Wizard will be started
4. Select one of the map types
5. Click the Execute button
6. Click Cancel to create an empty map

Adding New Items

1. Select any perspective
2. Click on the Align with button, select New... option
3. Fill in the required settings
4. Click Add new item

Export Map

Click the Export button on the toolbar to access the map export dialog.

Increase Export resolution to prepare a map for printing
Use Export without background to export map with transparent background

Change Mission Statement

1. Go to the KPI tab
2. Select root element
3. Enter the text in the Mission field below

Creating Map with KPIs

1. Go to the Strategy Map tab
2. Create a new map
3. Select Map with KPIs in the Placement Wizard

To link a KPI to a map area:

1. Go to the KPI tab
2. Right-click on any KPI
3. Select the Link item to the map option
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Dashboards in BSC Designer PRO
Learn how to present the most important information about KPIs and their trends on the BI dashboard in BSC Designer PRO.

Adding Charts to the Dashboard

1. Go to the Dashboard tab
2. Create a new dashboard if necessary
3. Select the Chart option in the Add... menu
4. Select the data source indicator
5. Select the type of the chart
6. Select the data to visualize (e.g. value, progress, or performance)
7. Click OK to finish

Additional Controls

Some charts have additional controls ; use them to:

Add more indicators to the chart
Change time period for the chart

Export Chart

Use the Export to image button to save the dashboard as an image file.
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Analysis in BSC Designer
Forecast the value of an indicator or find worthwhile performing indicators over a period of time with Analysis function in BSC Designer PRO.

Performance / Progress

Find top performing indicators, or indicators that were underperforming over a period of time.

Use the time controls at the bottom to change the time period
Change the sorting order by clicking on the Performance or Progress columns

Absolute Weight

The weight property of the indicator defines its relevant importance. Absolute weight analysis helps to find indicators that impact the
scorecard the most.

Forecast

The forecast analysis uses historical data and does a linear estimation for an indicator's value.

1. Go to the Analysis tab
2. Select the Forecast analysis
3. Select any indicator below
4. Enter a date in the Target date field
5. Check the Forecast value column for the forecasted value
6. Enter a value into the Target value field
7. Check the Forecast date column for the date when the entered value is expected

Value

Select an interval using the time controls. BSC Designer PRO will show:

The minimum and maximum value of an indicator
The average value over the period
The current value

Update Time

Update in shows when an indicator needs to be updated
Last updated shows the date when an indicator was updated the last time
Update each summarizes information about a required update interval

Biggest Gain/Loss
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Find indicators that changed significantly in terms of:

Performance,
Progress, or
Value.

Click on the Gain/Loss column to sort results.
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Performance Reports in BSC Designer PRO
Support presentations with performance data from business scorecard - create reports for goal performance and KPIs data.

Scorecard Performance Report

This report focuses on KPIs, their data, initiatives, and charts. Select in the report dialog:

The time period to report
Grouping settings for indicators
The level of the reporting details

Understanding Reports

Start and End are the value/performance for the start and end points of the report interval
Dynamic is the difference between the End value and Start value.
Max, Min, Average  are respectively maximum, minimum or average performance/progress over the reporting period
Current is the value for the date selected in the internal calendar

Goals and KPIs Report

Cost of Strategy - a summary of all initiatives with budget and duration data
Efforts vs. Results - a report with leading and lagging data for the goals
Action Plan - a report with goals, initiatives, and persons responsible

KPI Report

KPI Structure Report - a copy of the KPI tree from the KPI tab
Values Report - includes all values for indicators and stop lights
Key Risk Indicators Report - summarizes the estimation of the risk impact and probability
Data Series Report - shows the details for the indicators powered by data series

Other Reports

Strategy Map Report
Dashboard report
Analysis Report
MS Excel Report
MS PowerPoint Report

Customizing Reports
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Change report charts using the Tools > Application Options > Reports tab
Add logo using the Tools > Application Options > Company Info tab
Change charts colors using the Tools > Application Options > Chart colors tab

Reports in PDF

1. Generate any report
2. Click the Print button on the Report tab
3. Use any PDF printer
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Alerts in BSC Designer
Keep your team informed about new initiatives added, performance changes, or approaching update interval.

Teamwork Settings

There are two ways BSC Designer PRO can send out alerts:

BSC Designer Online (recommended) - get user list and send notifications via BSC Designer Online
Private mail server - provide your own mail server and manually introduce emails

Change teamwork settings in the menu Tools > Application Options > Teamwork > Provide teamwork functionality.

Creating a New Alert

Go to the Alerts tab and click the Add alert button.

On the General settings tab, select the application area
On the Event tab, select the trigger event
On the Notification tab, select the recipient
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